Emergency Database Maintenance

Incident Report for InterExchange

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 17:07 EST

Investigating

The App database will be down momentarily to perform a maintenance procedure.
Posted Feb 23, 2026 - 16:57 EST
This incident affected: InterExchange (App) and Au Pair USA (Passport).