App Performance Issues

Incident Report for InterExchange

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 19:07 EST

Monitoring

We're monitoring, conditions have been normal.
Posted Feb 24, 2026 - 11:09 EST

Identified

We're experiencing performance issues on App, we're devising solutions.
Posted Feb 24, 2026 - 08:59 EST
This incident affected: InterExchange (App).