Connectivity Issues

Incident Report for InterExchange

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 08:58 EST

Update

Providers have resolved the problem.
Posted Feb 21, 2026 - 01:07 EST

Monitoring

Our upstream provider's caching service is experiencing connectivity issues, we are monitoring.
Posted Feb 21, 2026 - 01:02 EST
This incident affected: InterExchange (App) and Au Pair USA (Passport).