Increased Error Rates

Incident Report for InterExchange

Resolved

The upstream issue has been resolved, all services are operational.
Posted Dec 16, 2025 - 08:56 EST

Monitoring

We have identified increased error rates in App and are investigating.
Posted Dec 16, 2025 - 02:18 EST
This incident affected: InterExchange (App).