Network Connectivity Issues.

Incident Report for InterExchange

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 11:54 EST

Monitoring

Various upstream providers are reporting network connectivity issues. Impact is currently limited on our systems, we are monitoring the situation.
Posted Feb 18, 2026 - 09:11 EST