Upstream Provider Networking Issues

Incident Report for InterExchange

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 14:30 EDT

Monitoring

Our upstream provider is reporting intermittent connectivity issues. Performance is returning to normal, will continue to monitor.
Posted Jun 04, 2026 - 13:33 EDT

Investigating

We are currently investigating the issue.
Posted Jun 04, 2026 - 13:05 EDT
This incident affected: InterExchange (App) and Au Pair USA (Passport).